HTTPD ERROR AH00287 AH00286 raising the MaxRequestWorkers setting

2020-05-15 KENNETH 0

AH00287 AH00286 raising the MaxRequestWorkers setting   에러로그 AH00287: server is within MinSpareThreads of MaxRequestWorkers, consider raising the MaxRequestWorkers setting AH00286: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting     조치사항   주의사항 MaxRequestWorkers 설정값을 올려줘야 하는데 그냥 무심코 올리면 이런식으로 경고가 발생한다 AH00316: WARNING: MaxRequestWorkers of 512 is not an integer multiple of ThreadsPerChild of 25, decreasing to nearest multiple 500, for a maximum of 20 servers. AH00318: WARNING: MaxRequestWorkers of 500 would require 20 servers and would exceed ServerLimit of 16, decreasing to 400. To increase, please see the ServerLimit directive. AH00316 : ThreadsPerChild 수치의 배수가 되게끔 설정해라 AH00318 : MaxRequestWorkers의 수치를 ThreadsPerChild의 수치로 나눈 몫이 ServerLimit의 수치보다 높아서는 안된다 ServerLimit 를 따로 설정하지 않은 경우 기본값 : 16  

[CVE-2020-1938] apache tomcat 취약점에 따른 업데이트시 참고 사항

2020-03-10 KENNETH 0

CVE-2020-1938 취약점 CVE : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-1938 KISA : https://www.krcert.or.kr/data/secNoticeView.do?bulletin_writing_sequence=35292APACHE : http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.100   취약점 해결을 위해서는 tomcat 을 최신버전으로 업데이트 해줘야 한다. 2020.03.10 기준 tomcat7 의 경우 7.0.100 버전 으로 tomcat8 의 경우 8.5.51 버전 으로 tomcat9 의 경우 9.0.31 버전 으로 업데이트를 해줘야 한다.   발단 tomcat7 을 사용중인 서버가 있어 기존 : tomcat-7.0.64 변경 : tomcat-7.0.100 으로 계획후 작업을 진행 별다른 이슈가 없을것으로 보였고, 작업을 진행했으나 문제 발생   발생한 문제점 1. 에러로그 발생 The AJP Connector is configured with secretRequired=”true” but the secret attribute is either null or “”. 기존에 존재하지 않았던 로그   2. 503 오류 발생 jsp 페이지 자체가 로딩되지 않는 문제가 있었다.     해결 1. secretRequired=”true” 참조 : https://tomcat.apache.org/tomcat-7.0-doc/changelog.html Rename the requiredSecret attribute of the AJP/1.3 Connector to secret and add a new attribute secretRequired that defaults to true. When secretRequired is true the AJP/1.3 [ more… ]

(28)No space left on device: AH00023: Couldn’t create the rewrite-map mutex in Apache

2018-09-01 KENNETH 0

  증상 아래 로그와 같이 아파치 실행이 되지 않는 문제 발생 이 에러 참으로 오랜만이다… 아마 마지막으로 본것이 10년은 족히 된것 같구나… 너무 오랜만이어서 대략적으로다가 순간 흠칫… ㄷ ㄷ ㄷ   에러 로그 [core:emerg] [pid 6744:tid 139704271460160] (28)No space left on device: AH00023: Couldn’t create the rewrite-map mutex AH00016: Configuration Failed   당장 처리 아파치 구동 유저가 “nobody”라는 가정 하에… ipcs -s |grep nobody|awk ‘{print $2}’ |xargs ipcrm -s 이후 아파치를 실행해 보면 정상 구동 될 것이다.   원인 리눅스의 세마포어(semaphore)와 관련이 있다.. 제한된 자원 할당량에 의해 더이상 자원을 사용하지 못한다고 생각 하면 될듯…   사용 현황 확인 # ipcs -s —— Semaphore Arrays ——– key semid owner perms nsems 0x00000000 236847104 root 666 1 0x00000000 236879873 root 666 1 0x00000000 236912642 nobody 600 1 0x00000000 236945411 nobody 600 1 0x00000000 87293956 nobody 600 1 0x00000000 87326725 nobody 600 1 [ more… ]

“options * http/1.0 200 – – apache (internal dummy connection)” in apache logfile

2018-08-01 KENNETH 0

로그메세지 options * http/1.0 200 – – apache (internal dummy connection)     원인 참고URL : https://wiki.apache.org/httpd/InternalDummyConnection 아파치가 새로운 커넥션에 대응 할 수 있도록 자식프로세스를 관리하는 방안으로 로컬접속을 시도한다.. 뭐.. 이런…     해결 문제가 있어서 발생 하는 내용은 아님 무시해도 됨 이지만…   SetEnvIf Remote_Addr “::1” do_not_log CustomLog logs/domain.com-access.log common env=!do_not_log 정도 처리를 해주면 된다.  

No Image

“configure: WARNING: nghttp2 version is too old” when compile httpd-2 support http2

2018-02-08 KENNETH 0

1. 오류 메세지 checking for pkg-config along … checking for nghttp2 version >= 1.2.1… FAILED configure: WARNING: nghttp2 version is too old   2. 상황 HTTP2(h2) 지원을 위해 아파치2 컴파일 중 발생   3. 서버 현황 OS : CentOS-6 or 7 apache : 2.4.29 nghttp2 : 1.21.1   분명 nghttp2 패키지는 설치 되어 있고 버전 요구 사항도 충족을 하고 있음에도… 버전이 오래되었다고 나옴 소스를 파볼 능력도 안되고, 파보지도 못했지만… – 소스에 문제가 있을 가능성을 직감 – 보통 require 를 위해 패키지를 설치할 경우 redhat 계열에서는 devel 패키지를 설치 해줘야 하는 상황을 미루어.. libnghttp2-devel 패키지를 설치 해줌 그랬더니 해결됨   이건 분명 “헤더파일을 찾을 수 없음” 류의 에러가 나오도록 소스가 수정되어야만 한다…. 아무리 따져봐도 “버전이 낮아서”는 아니지 않냐…. 개선좀 하자.. ;;