USN-3887-1: snapd vulnerability

USN-3887-1: snapd vulnerability

snapd vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

snapd could be made to run programs as an administrator.

Software Description

  • snapd – Daemon and tooling that enable snap packages

Details

Chris Moberly discovered that snapd versions 2.28 through 2.37 incorrectly
validated and parsed the remote socket address when performing access
controls on its UNIX socket. A local attacker could use this to access
privileged socket APIs and obtain administrator privileges. On Ubuntu
systems with snaps installed, snapd typically will have already
automatically refreshed itself to snapd 2.37.1 which is unaffected.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.10
snapd2.35.5+18.10.1
Ubuntu 18.04 LTS
snapd2.34.2+18.04.1
Ubuntu 16.04 LTS
snapd2.34.2ubuntu0.1
Ubuntu 14.04 LTS
snapd2.34.2~14.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

Source: USN-3887-1: snapd vulnerability

About KENNETH 10819 Articles
지락문화예술공작단

Be the first to comment

Leave a Reply

Your email address will not be published.


*


This site uses Akismet to reduce spam. Learn how your comment data is processed.