USN-3953-1: PHP vulnerabilities

USN-3953-1: PHP vulnerabilities

php7.0, php7.2 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Several security issues were fixed in PHP.

Software Description

  • php7.2 – HTML-embedded scripting language interpreter
  • php7.0 – HTML-embedded scripting language interpreter

Details

It was discovered that PHP incorrectly handled certain exif tags in JPEG
images. A remote attacker could use this issue to cause PHP to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
libapache2-mod-php7.27.2.17-0ubuntu0.19.04.1
php7.2-cgi7.2.17-0ubuntu0.19.04.1
php7.2-cli7.2.17-0ubuntu0.19.04.1
php7.2-fpm7.2.17-0ubuntu0.19.04.1
Ubuntu 18.10
libapache2-mod-php7.27.2.17-0ubuntu0.18.10.1
php7.2-cgi7.2.17-0ubuntu0.18.10.1
php7.2-cli7.2.17-0ubuntu0.18.10.1
php7.2-fpm7.2.17-0ubuntu0.18.10.1
Ubuntu 18.04 LTS
libapache2-mod-php7.27.2.17-0ubuntu0.18.04.1
php7.2-cgi7.2.17-0ubuntu0.18.04.1
php7.2-cli7.2.17-0ubuntu0.18.04.1
php7.2-fpm7.2.17-0ubuntu0.18.04.1
Ubuntu 16.04 LTS
libapache2-mod-php7.07.0.33-0ubuntu0.16.04.4
php7.0-cgi7.0.33-0ubuntu0.16.04.4
php7.0-cli7.0.33-0ubuntu0.16.04.4
php7.0-fpm7.0.33-0ubuntu0.16.04.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In Ubuntu 18.04 LTS, Ubuntu 18.10, and Ubuntu 19.04, this update uses a new
upstream release, which includes additional bug fixes.

In general, a standard system update will make all the necessary changes.

References

Source: USN-3953-1: PHP vulnerabilities

About KENNETH 11004 Articles
지락문화예술공작단

Be the first to comment

Leave a Reply

Your email address will not be published.


*


This site uses Akismet to reduce spam. Learn how your comment data is processed.