USN-4015-1: DBus vulnerability

USN-4015-1: DBus vulnerability

dbus vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

DBus could allow unintended access to services.

Software Description

  • dbus – simple interprocess messaging system

Details

Joe Vennix discovered that DBus incorrectly handled DBUS_COOKIE_SHA1
authentication. A local attacker could possibly use this issue to bypass
authentication and connect to DBus servers with elevated privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
dbus1.12.12-1ubuntu1.1
libdbus-1-31.12.12-1ubuntu1.1
Ubuntu 18.10
dbus1.12.10-1ubuntu2.1
libdbus-1-31.12.10-1ubuntu2.1
Ubuntu 18.04 LTS
dbus1.12.2-1ubuntu1.1
libdbus-1-31.12.2-1ubuntu1.1
Ubuntu 16.04 LTS
dbus1.10.6-1ubuntu3.4
libdbus-1-31.10.6-1ubuntu3.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

Source: USN-4015-1: DBus vulnerability

About KENNETH 11683 Articles
지락문화예술공작단

Be the first to comment

Leave a Reply

Your email address will not be published.


*


This site uses Akismet to reduce spam. Learn how your comment data is processed.