USN-4016-1: Vim vulnerabilities

USN-4016-1: Vim vulnerabilities

vim vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Several security issues were fixed in Vim.

Software Description

  • vim – Vi IMproved – enhanced vi editor

Details

It was discovered that Vim incorrectly handled certain files.
An attacker could possibly use this issue to execute arbitrary code.
This issue only affected Ubuntu 16.04 LTS. (CVE-2017-5953)

It was discovered that Vim incorrectly handled certain files.
An attacker could possibly use this issue to execute arbitrary code.
(CVE-2019-12735)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
vim2:8.1.0320-1ubuntu3.1
vim-common2:8.1.0320-1ubuntu3.1
vim-gui-common2:8.1.0320-1ubuntu3.1
vim-runtime2:8.1.0320-1ubuntu3.1
Ubuntu 18.10
vim2:8.0.1766-1ubuntu1.1
vim-common2:8.0.1766-1ubuntu1.1
vim-gui-common2:8.0.1766-1ubuntu1.1
vim-runtime2:8.0.1766-1ubuntu1.1
Ubuntu 18.04 LTS
vim2:8.0.1453-1ubuntu1.1
vim-common2:8.0.1453-1ubuntu1.1
vim-gui-common2:8.0.1453-1ubuntu1.1
vim-runtime2:8.0.1453-1ubuntu1.1
Ubuntu 16.04 LTS
vim2:7.4.1689-3ubuntu1.3
vim-common2:7.4.1689-3ubuntu1.3
vim-gui-common2:7.4.1689-3ubuntu1.3
vim-runtime2:7.4.1689-3ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

Source: USN-4016-1: Vim vulnerabilities

About KENNETH 11208 Articles
지락문화예술공작단

Be the first to comment

Leave a Reply

Your email address will not be published.


*


This site uses Akismet to reduce spam. Learn how your comment data is processed.