USN-4034-1: ImageMagick vulnerabilities

USN-4034-1: ImageMagick vulnerabilities

imagemagick vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Several security issues were fixed in ImageMagick.

Software Description

  • imagemagick – Image manipulation programs and library

Details

It was discovered that ImageMagick incorrectly handled certain malformed
image files. If a user or automated system using ImageMagick were tricked
into opening a specially crafted image, an attacker could exploit this to
cause a denial of service or possibly execute code with the privileges of
the user invoking the program.

Due to a large number of issues discovered in GhostScript that prevent it
from being used by ImageMagick safely, the update for Ubuntu 18.10 and
Ubuntu 19.04 includes a default policy change that disables support for the
Postscript and PDF formats in ImageMagick. This policy can be overridden if
necessary by using an alternate ImageMagick policy configuration.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
imagemagick8:6.9.10.14+dfsg-7ubuntu2.2
imagemagick-6.q168:6.9.10.14+dfsg-7ubuntu2.2
libmagick++-6.q16-88:6.9.10.14+dfsg-7ubuntu2.2
libmagickcore-6.q16-68:6.9.10.14+dfsg-7ubuntu2.2
libmagickcore-6.q16-6-extra8:6.9.10.14+dfsg-7ubuntu2.2
Ubuntu 18.10
imagemagick8:6.9.10.8+dfsg-1ubuntu2.2
imagemagick-6.q168:6.9.10.8+dfsg-1ubuntu2.2
libmagick++-6.q16-88:6.9.10.8+dfsg-1ubuntu2.2
libmagickcore-6.q16-68:6.9.10.8+dfsg-1ubuntu2.2
libmagickcore-6.q16-6-extra8:6.9.10.8+dfsg-1ubuntu2.2
Ubuntu 18.04 LTS
imagemagick8:6.9.7.4+dfsg-16ubuntu6.7
imagemagick-6.q168:6.9.7.4+dfsg-16ubuntu6.7
libmagick++-6.q16-78:6.9.7.4+dfsg-16ubuntu6.7
libmagickcore-6.q16-38:6.9.7.4+dfsg-16ubuntu6.7
libmagickcore-6.q16-3-extra8:6.9.7.4+dfsg-16ubuntu6.7
Ubuntu 16.04 LTS
imagemagick8:6.8.9.9-7ubuntu5.14
imagemagick-6.q168:6.8.9.9-7ubuntu5.14
libmagick++-6.q16-5v58:6.8.9.9-7ubuntu5.14
libmagickcore-6.q16-28:6.8.9.9-7ubuntu5.14
libmagickcore-6.q16-2-extra8:6.8.9.9-7ubuntu5.14

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

Source: USN-4034-1: ImageMagick vulnerabilities

About KENNETH 11320 Articles
지락문화예술공작단

Be the first to comment

Leave a Reply

Your email address will not be published.


*


This site uses Akismet to reduce spam. Learn how your comment data is processed.