USN-4133-1: Wireshark vulnerabilities

USN-4133-1: Wireshark vulnerabilities

Wireshark vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Wireshark could be made to crash if it received specially crafted network
traffic or input files.

Software Description

  • wireshark – network traffic analyzer

Details

It was discovered that Wireshark improperly handled certain input. A remote or
local attacker could cause Wireshark to crash by injecting malformed packets
onto the wire or convincing someone to read a malformed packet trace file.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
libwireshark-data2.6.10-1~ubuntu19.04.0
libwireshark112.6.10-1~ubuntu19.04.0
libwiretap82.6.10-1~ubuntu19.04.0
libwscodecs22.6.10-1~ubuntu19.04.0
libwsutil92.6.10-1~ubuntu19.04.0
tshark2.6.10-1~ubuntu19.04.0
wireshark2.6.10-1~ubuntu19.04.0
wireshark-common2.6.10-1~ubuntu19.04.0
wireshark-gtk2.6.10-1~ubuntu19.04.0
wireshark-qt2.6.10-1~ubuntu19.04.0
Ubuntu 18.04 LTS
libwireshark-data2.6.10-1~ubuntu18.04.0
libwireshark112.6.10-1~ubuntu18.04.0
libwiretap82.6.10-1~ubuntu18.04.0
libwscodecs22.6.10-1~ubuntu18.04.0
libwsutil92.6.10-1~ubuntu18.04.0
tshark2.6.10-1~ubuntu18.04.0
wireshark2.6.10-1~ubuntu18.04.0
wireshark-common2.6.10-1~ubuntu18.04.0
wireshark-gtk2.6.10-1~ubuntu18.04.0
wireshark-qt2.6.10-1~ubuntu18.04.0
Ubuntu 16.04 LTS
libwireshark-data2.6.10-1~ubuntu16.04.0
libwireshark112.6.10-1~ubuntu16.04.0
libwiretap82.6.10-1~ubuntu16.04.0
libwscodecs22.6.10-1~ubuntu16.04.0
libwsutil92.6.10-1~ubuntu16.04.0
tshark2.6.10-1~ubuntu16.04.0
wireshark2.6.10-1~ubuntu16.04.0
wireshark-common2.6.10-1~ubuntu16.04.0
wireshark-gtk2.6.10-1~ubuntu16.04.0
wireshark-qt2.6.10-1~ubuntu16.04.0

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

This update uses a new upstream release, which includes additional bug
fixes. In general, a standard system update will make all the necessary
changes.

References

Source: USN-4133-1: Wireshark vulnerabilities

About KENNETH 11878 Articles
지락문화예술공작단

Be the first to comment

Leave a Reply

Your email address will not be published.


*


This site uses Akismet to reduce spam. Learn how your comment data is processed.