USN-4405-1: GLib Networking vulnerability

USN-4405-1: GLib Networking vulnerability

glib-networking vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 20.04 LTS
  • Ubuntu 19.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Fraudulent security certificates could allow sensitive
information to be exposed when accessing the Internet.

Software Description

  • glib-networking – Network extensions for GLib

Details

It was discovered that glib-networking skipped hostname certificate
verification if the application failed to specify the server
identity. A remote attacker could use this to perform a
person-in-the-middle attack and expose sensitive information.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 20.04 LTS
glib-networking2.64.2-1ubuntu0.1
Ubuntu 19.10
glib-networking2.62.1-1ubuntu0.1
Ubuntu 18.04 LTS
glib-networking2.56.0-1ubuntu0.1
Ubuntu 16.04 LTS
glib-networking2.48.2-1~ubuntu16.04.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

Source: USN-4405-1: GLib Networking vulnerability

About KENNETH 13404 Articles
지락문화예술공작단

Be the first to comment

Leave a Reply

Your email address will not be published.


*


이 사이트는 스팸을 줄이는 아키스밋을 사용합니다. 댓글이 어떻게 처리되는지 알아보십시오.